SBS2003 Exchange POP3 Connector Polling Interval

A quick registry fix revealed here shows how to increase the POP3 email retrieval speed on Small Business Server 2003.  Yes, having SMTP mail delivered directly to the server is better, but first things first!

1. Locate and then click the following registry subkey:
“HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/SmallBusinessServer/Network/POP3 Connector”

2. On the “Edit” menu, point to “New”, and then click “DWORD Value”.

3. Type “ScheduleAccelerator” as the entry name, and then press ENTER.

5. On the “Edit” menu, click “Modify”.

6. In the “Value data” box, type the value that you want, and then click “OK”.  To determine the polling interval, the value that is configured on the “Scheduling” tab in the GUI is divided by the value that you type for the ScheduleAccelerator entry. For example, if a 15 minute interval is specified in the GUI and you set the value of the ScheduleAccelerator entry to 3, the connector will poll every five minutes.

7. Quit Registry Editor and restart the “Microsoft Connector for POP3 Mailboxes” service.

Note: I’m not entirely convinced that the “[GUI Interval]/[ScheduleAccelerator]=[Minutes]” theory is correct.  With the server set at 15/5, I should get polling every 3 minutes, but it seems to be more like 45 seconds.  With it set at 15/3, I am getting mixed results between 30 seconds and 5 minutes.  I guess that’s good enough for government work; YMMV.

8 replies
  1. Erik
    Erik says:

    I just spent 30 mins taking time for POP intervals with 15/3 settings and I got:

    2:30
    3:32
    5:09
    0:30
    0:49
    1:10
    1:29
    2:11
    3:32
    5:11
    0:30
    0:50
    1:09
    1:30

    thanks for the info

    Reply
  2. Matthias Henning
    Matthias Henning says:

    Should have mentioned: My initial setting was: ‘3’ thus the POP3connector SHOULD have polled every 5min (15/3=5).

    Reply
  3. Matthias Henning
    Matthias Henning says:

    Your are rgiht having doubts with regards to the interval accuracy mentioned in your note. My provider recently called (!) complaining about my server polling mail in intervals of 10 to 30 sec, with no recognizable pattern – stressing their server’s performance I was told.
    Using Sysinternal’s ‘process explorer’ quickly proved my provider right.

    Thus: Carefull with that tweak – it could cause problems!

    Many thanks Jeremy to provide that hint, couldn’t find it elsewhere, much appriciated. Cheers Matt.

    Reply

Trackbacks & Pingbacks

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply to Christian Louboutin Cancel reply

Your email address will not be published. Required fields are marked *